Friday, May 04, 2012

Resolve JDBC incompatibility problem between ORACLE SQL Developer and ODAC

Check new series of the articles. Review and user experience on test management systems. Functionality and usability.
-------------------

Once tried to connect to Oracle DB server with Oracle SQL developer I got the following error message
Status : Failure -Test failed: Incompatible version of libocijdbc[Jdbc:112020, Jdbc-OCI:112030
After certain investigation and attempts to get connection established using different configurations I figured out the following root cause. The problem was in latest version of ODAC installed on my PC. Downloading and installing ODAC of version 11.2.0.2.1 eliminated the problem. Connection was then established successfully. In other words the latest Oracle SQL developer release does not properly work with the latest ODAC release

UPD: Looks like the compatibility of the latest ODAC+latest SQL Developer should be fine for now (March'13).